Data Processing Delays - USPS Tracking Events

Incident Report for Lob

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 11:05 PDT

Monitoring

We've resolved the issue that prevented ingestion of USPS tracking events. USPS has sent us a backfill file, and we are currently processing the skipped events. Customers should see all tracking events caught up by the end of business today.
Posted Aug 12, 2026 - 08:29 PDT

Identified

We are currently experiencing an issue affecting ingestion of USPS tracking events. All tracking events will be delayed until this issue is resolved and the backlog of data is processed. Our team is aware of the issue and actively implementing a fix.
Posted Aug 12, 2026 - 07:22 PDT
This incident affected: Dashboard.