Delays in processing campaigns
Incident Report for Lob
Resolved
The issue has been fixed
Posted Sep 26, 2023 - 15:44 PDT
Update
We are investigating delays in the processing campaigns at this time
Posted Sep 26, 2023 - 15:16 PDT
Investigating
We are investigating delays in the processing of some Campaigns at this time
Posted Sep 26, 2023 - 15:15 PDT