Rendering Service Delays

Incident Report for Lob

Resolved

This incident has been resolved.
Posted May 05, 2026 - 14:40 PDT

Monitoring

Issue seem to be resolved. We are monitoring.
Posted May 05, 2026 - 11:08 PDT

Investigating

Our rendering system is experiencing delays so proofs and thumbnails may lake longer than expected to appear in the dashboard. We have identified the issue and are actively working on a fix
Posted May 05, 2026 - 10:34 PDT