Rendering delays

Incident Report for Lob

Resolved

We experienced delays with rendering that caused proofs and thumbnails to appear slower than usual in the dashboard. The issue has been identified and resolved. Systems are now operating normally. We appreciate your patience and understanding.
Posted Jun 06, 2025 - 12:55 PDT

Identified

We are currently experiencing delays with rendering. As a result, proofs and thumbnails may take longer than usual to appear in the dashboard. We've identified the root cause and are actively working on a fix.
Posted Jun 06, 2025 - 11:47 PDT