Degraded performance for Dashboard Search
Incident Report for Lob
Resolved
This incident has been resolved.
Posted Aug 29, 2020 - 13:45 PDT
Identified
Dashboard search and other pages may be performing slowly. We've identified the issue and are working on a fix.
Posted Aug 28, 2020 - 13:36 PDT
This incident affected: Dashboard.