Temporary outage for letters

Incident Report for Lob

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 10, 2026 - 15:00 PDT

Monitoring

Customers may have experienced a temporary outage related to creating letters and obtaining information about previously created letters.  The root cause has been identified and the issue resolved.
Posted Jun 10, 2026 - 14:50 PDT
This incident affected: API and Dashboard.