Dashboard Data Delays

Incident Report for Lob

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 13:59 PST

Identified

Our engineering team has observed data delays in our dashboard. Data may be stale or missing. Our engineering team is actively working on a resolution.
Posted Dec 09, 2025 - 10:06 PST