Delayed Postcard Search Results in Dashboard
Incident Report for Lob
Resolved
This incident has been resolved.
Posted Sep 19, 2019 - 07:38 PDT
Identified
We're experiencing delays with Postcards showing up in Dashboard for our Search and List Pages.
Posted Sep 18, 2019 - 10:43 PDT
This incident affected: Home Page and Dashboard.