Data Processing Delays - Records not forwarded to Search service

Incident Report for Lob

Resolved

On August 6, 2025, between approximately 17:30 UTC and 22:50 UTC, some mail piece records were not forwarded to the Search service. Records that were created or updated after that time are being processed correctly.

We completed backfills overnight for all affected customers. If you are still seeing issues or have other concerns, please reach out to Lob support.
Posted Aug 07, 2025 - 05:35 PDT

Monitoring

On August 6, 2025, between approximately 17:30 UTC and 22:50 UTC, some mail piece records were not forwarded to the Search service. Records that were created or updated after that time are being processed correctly.

If you created a mail piece in that time window, or if the status of that mail piece changed within the Lob system, it may not be accurately reflected in the Lob dashboard. We are currently working to backfill the records in question.

In the interim, customers can reference the API logs in the Lob dashboard to confirm that mail pieces were successfully created in the Lob system. Please reach out to Lob support with any further questions.
Posted Aug 06, 2025 - 17:03 PDT
This incident affected: Dashboard and Webhooks.