Issues exporting mail data

Incident Report for Lob

Resolved

The issue causing export requests to experience significant delays or failures has been fixed. Export functionality is now operating normally.
Posted Jun 13, 2025 - 10:42 PDT

Investigating

We are currently experiencing issues Exporting mail data. We are investigating the issue and apologize for the inconvenience
Posted Jun 11, 2025 - 12:35 PDT