Rendering Delays

Incident Report for Lob

Resolved

All systems are operating normally. Issue is resolved.
Posted Apr 07, 2026 - 11:46 PDT

Investigating

Our rendering system is experiencing delays so proofs and thumbnails may lake longer than expected to appear in the dashboard, we have identified the issue and are actively fixing it
Posted Apr 07, 2026 - 10:32 PDT
This incident affected: API and Dashboard.