International verifications returning 500s

Incident Report for Lob

Resolved

This incident has been resolved. All services are operational.
Posted May 25, 2025 - 08:50 PDT

Identified

We are currently experiencing a service disruption affecting our international address verification service for countries outside the US, UK, Canada, and Mexico. Requests for address verification in all other countries are currently returning errors (HTTP 500).

Verification services for the US, UK, Canada, and Mexico remain fully operational.
Posted May 24, 2025 - 15:40 PDT