Users Unable to Complete Account Sign-Up

Incident Report for Lob

Resolved

The issue affecting new account registrations on the Dashboard has been resolved. Users should now be able to successfully create new accounts. We will continue to monitor the system to ensure stability.
Posted Mar 30, 2026 - 11:51 PDT

Investigating

We are currently experiencing an issue affecting new account registration on the Dashboard. Some users may be unable to create a new account at this time. Our team is aware of the issue and is actively investigating and implementing a fix.
Posted Mar 30, 2026 - 09:52 PDT