Delays viewing Previews, Proofs and Thumbnails from the Lob dashboard
Incident Report for Lob
Resolved
This should be fixed now. We apologize for the inconvenience
Posted Aug 07, 2024 - 13:39 PDT
Identified
We are experiencing delays viewing Previews, Proofs and Thumbnails from the Lob dashboard. We are fixing the problem at this time. We apologize for the inconvenience.
Posted Aug 07, 2024 - 12:12 PDT