Campaign Processing Delays
Incident Report for Lob
Resolved
The issue has been fixed.
Posted Jul 24, 2023 - 14:02 PDT
Investigating
We are investigating delays in processing of some campaigns uploaded to our dashboard
Posted Jul 24, 2023 - 13:26 PDT