Issue uploading CSVs for Campaigns
Incident Report for Lob
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 16:10 PDT
Investigating
We are currently experiencing an issue uploading CSVs. We are investigating the issue. We apologize for the inconvenience
Posted Sep 25, 2024 - 11:57 PDT
This incident affected: Dashboard.