Delays viewing Previews, Proofs and Thumbnails from the Lob dashboard
Incident Report for Lob
Resolved
This should be fixed now. We apologize for the inconvenience
Posted Aug 15, 2024 - 16:41 PDT
Identified
You might experience delays viewing Previews, Proofs and Thumbnails from the Lob dashboard. We apologize for the inconvenience.
Posted Aug 15, 2024 - 10:41 PDT