Escalated Error Rates
Incident Report for Lob
Resolved
All services have recovered.
Posted 19 days ago. Apr 01, 2019 - 10:01 PDT
Investigating
We are experiencing an escalated rate of errors across our API, dashboard, and lob.com. We are diagnosing the issue now.
Posted 19 days ago. Apr 01, 2019 - 09:36 PDT
This incident affected: API and Home Page and Dashboard.