Elevated API Errors

Incident Report for Lob

Resolved

This incident has been resolved. All endpoints and services are operational.
Posted May 30, 2025 - 10:59 PDT

Investigating

We're experiencing an elevated level of API errors on our US verifications and reverse geocode lookup endpoints. We are currently looking into the issue.
Posted May 30, 2025 - 10:17 PDT
This incident affected: API.