Email Delivery Issue (Resolved)

Incident Report for Lob

Resolved

This incident has been resolved.
Posted May 02, 2025 - 12:43 PDT

Update

We experienced an issue sending emails between Apr 29 at 10:45 AM PT and Apr 30 at 10:45 AM PT. Our team is currently in the process of resending the affected emails. If you were expecting an email during this time and have not received it, please contact us at support@lob.com.
We apologize for the inconvenience and appreciate your patience.
Posted May 01, 2025 - 15:08 PDT

Monitoring

We experienced an issue sending emails between Apr 29 at 10:45 AM PT and Apr 30 at 10:45 AM PT. Our team is currently in the process of resending the affected emails. If you were expecting an email during this time and have not received it, please contact us at support@lob.com.
We apologize for the inconvenience and appreciate your patience.
Posted May 01, 2025 - 11:46 PDT