Campaign/Mailpieces failing with 403 error

Incident Report for Lob

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 10, 2026 - 15:32 PDT

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 10, 2026 - 15:32 PDT